炒股知识 | 股票形态 | 技术指标 | 炒股技巧 | 看盘经验 | 美股港股 | 股指期权 | 专家股评 | 股市动态 | 书籍视频 | 网站地图
您的位置:首页 > 炒股知识 > 飞狐股票公式之自动测幅

飞狐股票公式之自动测幅

2018-02-09 16:25:30 作者:admin 点击:

飞狐股票公式有哪些?下面股票知识网为您介绍飞狐股票公式之自动测幅。{KG1;20;F1;10;N;10,P;2,Q;30,K,15}kg1:=20;F1:=10;N:=1

  飞狐股票公式有哪些?下面股票知识网为您介绍飞狐股票公式之自动测幅。

  {KG1;20;F1;10;N;10,P;2,Q;30,K,15}

  kg1:=20;

  F1:=10;

  N:=10;

  P:=2;

  Q:=30;

  K:=15;

  DRAWGBK(CLOSE》0,COLORRGB(0,0,0),COLORRGB(0,0,0),1);

  VAR51:=EMA(CLOSE,3);

  VAR52:=EMA(CLOSE,8);

  MA5:=MA(CLOSE,5),Color332900;

  MA21:=EMA(CLOSE,21);

  STICKLINE(VAR51《MA21,h,l,0,0),Colorgreen;

  STICKLINE(VAR51《MA21,c,o,8,0),Color10b210;

  STICKLINE(VAR51《MA21,c,o,5,0),Color10c110;

  STICKLINE(VAR51《MA21,c,o,2,0),Color10dd10;

  STICKLINE(VAR51》MA21,h,l,0,0),Color106fff;

  STICKLINE(VAR51》MA21,c,o,8,0),Color1047FF;

  STICKLINE(VAR51》MA21,c,o,5,0),Color1055ff;

  STICKLINE(VAR51》MA21,c,o,2,0),Color106fff;

  STICKLINE(VAR51《VAR52 AND VAR51》MA21,h,l,0,0),Colorff5d10;

  STICKLINE(VAR51《VAR52 AND VAR51》MA21,c,o,8,0),Colorff5d10;

  STICKLINE(VAR51《VAR52 AND VAR51》MA21,c,o,5,0),Colorff7710;

  STICKLINE(VAR51《VAR52 AND VAR51》MA21,c,o,2,0),Colorff9910;

  STICKLINE(VAR51》VAR52 AND VAR51《MA21,h,l,0,0),Colorff00ff;

  STICKLINE(VAR51》VAR52 AND VAR51《MA21,c,o,8,0),ColorFF43FF;

  STICKLINE(VAR51》VAR52 AND VAR51《MA21,c,o,5,0),Colorff63ff;

  STICKLINE(VAR51》VAR52 AND VAR51《MA21,c,o,2,0),Colorff83ff;

  KG:=IF(DATATYPE《=1,1,IF(DATATYPE《=3,5,IF(DATATYPE《=5,10,KG1)));

  F:=IF(DATATYPE《=3,1,IF(DATATYPE=4,3,IF(DATATYPE=5,5,F1)));

  ZX:=ZIG(4,KG);

  CCH:=PEAK(4,KG,1);

  CCY:=TROUGH(4,KG,1);

  CC:=IF(ZX《REF(ZX,1),CCH,CCY),LINETHICK0;

  W1:=CROSS(CCH-0.02,ZX);

  W2:=CROSS(ZX,CCY+0.02);

  FD:=F/100;

  YS:=IF(ZX《REF(ZX,1),FD,-FD);

  W:=IF(ZX《REF(ZX,1),W1,W2);

  H1:REF(CC*(1-YS*1),BARSLAST(W)),LINETHICK0;

  H2:REF(CC*(1-YS*2),BARSLAST(W)),LINETHICK0;

  H3:REF(CC*(1-YS*3),BARSLAST(W)),LINETHICK0;

  H4:REF(CC*(1-YS*4),BARSLAST(W)),LINETHICK0;

  H5:REF(CC*(1-YS*5),BARSLAST(W)),LINETHICK0;

  H6:REF(CC*(1-YS*6),BARSLAST(W)),LINETHICK0;

  H7:REF(CC*(1-YS*7),BARSLAST(W)),LINETHICK0;

  H8:REF(CC*(1-YS*8),BARSLAST(W)),LINETHICK0;

  H9:REF(CC*(1-YS*9),BARSLAST(W)),LINETHICK0;

  H10:REF(CC*(1-YS*10),BARSLAST(W)),LINETHICK0;

  H11:REF(CC*(1-YS*11),BARSLAST(W)),LINETHICK0;

  H12:REF(CC*(1-YS*12),BARSLAST(W)),LINETHICK0;

  H13:REF(CC*(1-YS*13),BARSLAST(W)),LINETHICK0;

  H14:REF(CC*(1-YS*14),BARSLAST(W)),LINETHICK0;

  H15:REF(CC*(1-YS*15),BARSLAST(W)),LINETHICK0;

  HHD:=SYSPARAM(4);

  LLD:=SYSPARAM(5);

  系数:=IF(DATATYPE=2,1.00005,IF(DATATYPE《6,1.0005,1.002));

  STICKLINE(CC》=LLD AND CC《=HHD,CC,CC*系数,20,0),colorFF;

  STICKLINE(CC》=LLD AND CC《=HHD,H1,H1,5,0),colorA0A0A0;

  STICKLINE(H1》LLD AND H1《HHD,H2,H2,5,0),colorA0A0A0;

  STICKLINE(H2》LLD AND H2《HHD,H3,H3,5,0),colorA0A0A0;

  STICKLINE(H3》LLD AND H3《HHD,H4,H4,5,0),colorA0A0A0;

  STICKLINE(H4》LLD AND H4《HHD,H5,H5,5,0),colorA0A0A0;

  STICKLINE(H5》LLD AND H5《HHD,H6,H6,5,0),colorA0A0A0;

  STICKLINE(H6》LLD AND H6《HHD,H7,H7,5,0),colorA0A0A0;

  STICKLINE(H7》LLD AND H7《HHD,H8,H8,5,0),colorA0A0A0;

  STICKLINE(H8》LLD AND H8《HHD,H9,H9,5,0),colorA0A0A0;

  STICKLINE(H9》LLD AND H9《HHD,H10,H10,5,0),colorA0A0A0;

  STICKLINE(H10》LLD AND H10《HHD,H11,H11,5,0),colorA0A0A0;

  STICKLINE(H11》LLD AND H11《HHD,H12,H12,5,0),colorA0A0A0;

  STICKLINE(H12》LLD AND H12《HHD,H13,H13,5,0),colorA0A0A0;

  STICKLINE(H13》LLD AND H13《HHD,H14,H14,5,0),colorA0A0A0;

  STICKLINE(H14》LLD AND H14《HHD,H15,H15,5,0),colorA0A0A0;

  DRAWTEXT(W AND CC》=LLD AND CC《=HHD,H1,‘’+NUMTOSTR(F*1,0)+‘%’),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H1》LLD AND H1《HHD,H2,‘’+NUMTOSTR(F*2,0)+‘%’),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H2》LLD AND H2《HHD,H3,‘’+NUMTOSTR(F*3,0)+‘%’),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H3》LLD AND H3《HHD,H4,‘’+NUMTOSTR(F*4,0)+‘%’),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H4》LLD AND H4《HHD,H5,‘’+NUMTOSTR(F*5,0)+‘%’),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H5》LLD AND H5《HHD,H6,‘’+NUMTOSTR(F*6,0)+‘%’),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H6》LLD AND H6《HHD,H7,‘’+NUMTOSTR(F*7,0)+‘%’),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H7》LLD AND H7《HHD,H8,‘’+NUMTOSTR(F*8,0)+‘%’),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H8》LLD AND H8《HHD,H9,‘’+NUMTOSTR(F*9,0)+‘%’),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H9》LLD AND H9《HHD,H10,‘’+NUMTOSTR(F*10,0)+‘%’),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H10》LLD AND H10《HHD,H11,‘’+NUMTOSTR(F*11,0)+‘%’),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H11》LLD AND H11《HHD,H12,‘’+NUMTOSTR(F*12,0)+‘%’),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H12》LLD AND H12《HHD,H13,‘’+NUMTOSTR(F*13,0)+‘%’),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H13》LLD AND H13《HHD,H14,‘’+NUMTOSTR(F*14,0)+‘%’),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H14》LLD AND H14《HHD,H15,‘’+NUMTOSTR(F*15,0)+‘%’),PXDN5,colorA0A0A0;

  AK1:=BARSLAST(W1)+1;

  BK1:=BARSLAST(W2)+1;

  目前:=IF(BK1》AK1,AK1,BK1);

  DRAWNUMBER(W1,CC,REF(目前,1),0),ALIGN2,PXUP30,colorFF00FF;

  DRAWNUMBER(W2,CC,REF(目前,1),0),ALIGN2,PXDN10,coloryellow;

  方向:=IF(CC=CCH,‘下行 ’,‘上升 ’);

  周期:=IF(DATATYPE=6,‘天 ’,IF(DATATYPE=7,‘周 ’,IF(DATATYPE=8,‘月 ’,‘单位’)));

  DRAWTEXTEX(CLOSE》0,0,2,5,‘目前波段’+方向+NUMTOSTR(目前,0)+周期);

  DRAWTEXT(W1,CC,‘’+周期),PXUP30,colorFF00FF;

  DRAWTEXT(W2,CC,‘’+周期),PXDN10,colorYELLOW;

  红山水:MA(MA(CLOSE,3),1),LINETHICK2,COLORFF0000;

  绿山水:MA(MA(CLOSE,3),3),LINETHICK2,COLORFF0000;

  partline(红山水》绿山水,红山水),LINETHICK2,COLORFF;

  partline(红山水》绿山水,绿山水),LINETHICK2,COLORFFFF00;

  ZF:=(EMA(SUM(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)),3),49)*10)+EMA(C,20);

  飞扬古:(EMA(MA(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)),3),13) * 10000),LINETHICK0,colorFFFFFF;

  【康熙帝】:EMA(ZF,34),LINETHICK2,colorFFFF;

  ZFF:=(EMA(SUM(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)),3),49) * 10000);;

  康熙帝:EMA(ZFF,34),LINETHICK0,colorFFFF;

  大1:=MA(ZFF,3);

  旗1:=MA(大1,3);

  展1:=MA(旗1,3);

  大:MA(ZF,3),color66DDFF;

  旗:MA(大,3),color66CCFF;

  展:MA(旗,3),color66AAFF;

  热:MA(展,3),color9900FF;

  血:MA(热,3),color7700FF;

  染:MA(血,3),colorFF;

  PARTLINE((大 《 REF(大,1)),大),colorCCCCCC;

  PARTLINE((旗 《 REF(旗,1)),旗),colorBBBBBB;

  PARTLINE((展 《 REF(展,1)),展),color999999;

  PARTLINE((热 《 REF(热,1)),热),color888888;

  PARTLINE((血 《 REF(血,1)),血),color777777;

  PARTLINE((染 《 REF(染,1)),染),color555555;

  GRR:COST(50)*0.98,LINETHICK2,colorGREEN;

  更多股票公式知识请关注股票知识网

  

Powered by www.en2o.com